import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Phone:\\s*\\({0,1}(\\d{3})\\){0,1}\\s*(\\d{3})-*(\\d{4})\\n{0,1}";
final String string = "Phone: (630) 690-0336\\nFax: (630) 355-0197\n"
+ "Phone: (630) 6900336\\nFax: (630) 355-0197\n"
+ "Fax: (630) 355-0197\\nPhone: (630) 6900336";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}