package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Phone:\s*\({0,1}(\d{3})\){0,1}\s*(\d{3})-*(\d{4})\n{0,1}`)
var str = `Phone: (630) 690-0336\nFax: (630) 355-0197
Phone: (630) 6900336\nFax: (630) 355-0197
Fax: (630) 355-0197\nPhone: (630) 6900336`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}