#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)((?:mr|ms) )?(.).* (.*)"
Local $sString = "Mr Andrew Smith" & @CRLF & _
"Mr A Smith" & @CRLF & _
"A Smith" & @CRLF & _
"Andrew Smith"
Local $sSubst = "\1\2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)