use strict;
my $str = 'Mr Andrew Smith
Mr A Smith
A Smith
Andrew Smith';
my $regex = qr/((?:mr|ms) )?(.).* (.*)/ip;
my $subst = '\\1\\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";