const regex = /((?:mr|ms) )?(.).* (.*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:mr|ms) )?(.).* (.*)', 'gi')
const str = `Mr Andrew Smith
Mr A Smith
A Smith
Andrew Smith`;
const subst = `\1\2 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);