$re = '/((?:mr|ms) )?(.).* (.*)/i';
$str = 'Mr Andrew Smith
Mr A Smith
A Smith
Andrew Smith';
$subst = "\1\2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;