using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:mr|ms) )?(.).* (.*)";
string substitution = @"\1\2 \3";
string input = @"Mr Andrew Smith
Mr A Smith
A Smith
Andrew Smith";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}