re = /((?:mr|ms) )?(.).* (.*)/i
str = 'Mr Andrew Smith
Mr A Smith
A Smith
Andrew Smith'
subst = '\\1\\2 \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result