#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " - |- | -"
Local $sString = "[ 'WOMEN\'S CC CROPPED TOP T-SHIRT -WHITE - L' ]" & @CRLF & _
"[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M' ]" & @CRLF & _
"[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L' ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")