re = / - |- | -/
str = '[ \'WOMEN\\\'S CC CROPPED TOP T-SHIRT -WHITE - L\' ]
[ \'WOMEN\\\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M\' ]
[ \'WOMEN\\\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L\' ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end