import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " - |- | -";
final String string = "[ 'WOMEN\\'S CC CROPPED TOP T-SHIRT -WHITE - L' ]\n"
+ "[ 'WOMEN\\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M' ]\n"
+ "[ 'WOMEN\\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L' ]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}