package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` - |- | -`)
var str = `[ 'WOMEN\'S CC CROPPED TOP T-SHIRT -WHITE - L' ]
[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M' ]
[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L' ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}