#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<html\>(?!html)([\s\S]*)<\/html\>"
Local $sString = "" & @CRLF & _
"This is text" & @CRLF & _
"<html>" & @CRLF & _
" <div>" & @CRLF & _
" some content" & @CRLF & _
" </div>" & @CRLF & _
"</html>" & @CRLF & _
"" & @CRLF & _
"This is more text" & @CRLF & _
"<html>" & @CRLF & _
" <div>" & @CRLF & _
" some content" & @CRLF & _
" </div>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")