import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<html\\>(?!html)([\\s\\S]*)<\\/html\\>";
final String string = "\n"
+ "This is text\n"
+ "<html>\n"
+ " <div>\n"
+ " some content\n"
+ " </div>\n"
+ "</html>\n\n"
+ "This is more text\n"
+ "<html>\n"
+ " <div>\n"
+ " some content\n"
+ " </div>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}