$re = '/<html\>(?!html)([\s\S]*)<\/html\>/';
$str = '
This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);