using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<html\>(?!html)([\s\S]*)<\/html\>";
string input = @"
This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}