use strict;
my $str = '
This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
';
my $regex = qr/<html\>(?!html)([\s\S]*)<\/html\>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}