const regex = /<html\>(?!html)([\s\S]*)<\/html\>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<html\\>(?!html)([\\s\\S]*)<\\\/html\\>', '')
const str = `
This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}