#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[parameter\K(?:\\[\]\[]|[^\[\]])*"
Local $sString = "Some " & @CRLF & _
"[parameter=value\[anoter value|subparam=20] with or " & @CRLF & _
"[parameter|value\]anoter value|subparam=21|nothing] or " & @CRLF & _
"[parameter=value\[anoter value\]|subparam=22] ";" & @CRLF & _
"foo bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")