re = /\[parameter\K(?:\\[\]\[]|[^\[\]])*/m
str = 'Some
[parameter=value\\[anoter value|subparam=20] with or
[parameter|value\\]anoter value|subparam=21|nothing] or
[parameter=value\\[anoter value\\]|subparam=22] ";
foo bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end