import re
regex = re.compile(r"\[parameter\K(?:\\[\]\[]|[^\[\]])*", flags=re.MULTILINE)
test_str = ("Some \n"
"[parameter=value\\[anoter value|subparam=20] with or \n"
"[parameter|value\\]anoter value|subparam=21|nothing] or \n"
"[parameter=value\\[anoter value\\]|subparam=22] \";\n"
"foo bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")