using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[parameter\K(?:\\[\]\[]|[^\[\]])*";
string input = @"Some
[parameter=value\[anoter value|subparam=20] with or
[parameter|value\]anoter value|subparam=21|nothing] or
[parameter=value\[anoter value\]|subparam=22] "";
foo bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}