$re = '/\[parameter\K(?:\\\\[\]\[]|[^\[\]])*/m';
$str = 'Some
[parameter=value\\[anoter value|subparam=20] with or
[parameter|value\\]anoter value|subparam=21|nothing] or
[parameter=value\\[anoter value\\]|subparam=22] ";
foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);