import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[parameter\\K(?:\\\\[\\]\\[]|[^\\[\\]])*";
final String string = "Some \n"
+ "[parameter=value\\[anoter value|subparam=20] with or \n"
+ "[parameter|value\\]anoter value|subparam=21|nothing] or \n"
+ "[parameter=value\\[anoter value\\]|subparam=22] \";\n"
+ "foo bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}