using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\/)SJD";
string input = @"<project name=""Pomost.SJD"" default=""all"" basedir=""."">
<property name=""projectName"" value=""sac_SJD""/>
<fileset dir=""${libDir}"" includes=""sac_SJD.jar""/>
<replaceregexp flags=""g"" match=""SJD"" replace=""OZPS"" file=""../ozps/build.xml""/>
<replaceregexp flags='g' match='""\/CAS\/SJD""' replace='""/CAS/OZPS""'>
<replaceregexp flags=""g"" match=""SJD"" replace=""OZPS"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}