const regex = /(?<!\/)SJD/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\/)SJD', 'g')
const str = `<project name="Pomost.SJD" default="all" basedir=".">
<property name="projectName" value="sac_SJD"/>
<fileset dir="\${libDir}" includes="sac_SJD.jar"/>
<replaceregexp flags="g" match="SJD" replace="OZPS" file="../ozps/build.xml"/>
<replaceregexp flags='g' match='"\\/CAS\\/SJD"' replace='"/CAS/OZPS"'>
<replaceregexp flags="g" match="SJD" replace="OZPS">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}