use strict;
my $str = '<project name="Pomost.SJD" default="all" basedir=".">
<property name="projectName" value="sac_SJD"/>
<fileset dir="${libDir}" includes="sac_SJD.jar"/>
<replaceregexp flags="g" match="SJD" replace="OZPS" file="../ozps/build.xml"/>
<replaceregexp flags=\'g\' match=\'"\\/CAS\\/SJD"\' replace=\'"/CAS/OZPS"\'>
<replaceregexp flags="g" match="SJD" replace="OZPS">';
my $regex = qr/(?<!\/)SJD/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}