import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\/)SJD";
final String string = "<project name=\"Pomost.SJD\" default=\"all\" basedir=\".\">\n"
+ "<property name=\"projectName\" value=\"sac_SJD\"/>\n"
+ "<fileset dir=\"${libDir}\" includes=\"sac_SJD.jar\"/>\n"
+ "<replaceregexp flags=\"g\" match=\"SJD\" replace=\"OZPS\" file=\"../ozps/build.xml\"/>\n"
+ "<replaceregexp flags='g' match='\"\\/CAS\\/SJD\"' replace='\"/CAS/OZPS\"'>\n"
+ "<replaceregexp flags=\"g\" match=\"SJD\" replace=\"OZPS\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}