#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+(?<!Test1)\.dbo\.MyTable"
Local $sString = "Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable" & @CRLF & _
"Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable" & @CRLF & _
"foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable" & @CRLF & _
"" & @CRLF & _
"Test1.dbo.MyTable" & @CRLF & _
"Test2.dbo.MyTable" & @CRLF & _
"Test123.dbo.MyTable" & @CRLF & _
"Test223.dbo.MyTable"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")