$re = '/\w+(?<!Test1)\.dbo\.MyTable/';
$str = 'Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable
Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable
foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable
Test1.dbo.MyTable
Test2.dbo.MyTable
Test123.dbo.MyTable
Test223.dbo.MyTable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);