import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?<!Test1)\\.dbo\\.MyTable";
final String string = "Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable\n"
+ "Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable\n"
+ "foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable\n\n"
+ "Test1.dbo.MyTable\n"
+ "Test2.dbo.MyTable\n"
+ "Test123.dbo.MyTable\n"
+ "Test223.dbo.MyTable";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}