re = /\w+(?<!Test1)\.dbo\.MyTable/
str = 'Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable
Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable
foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable
Test1.dbo.MyTable
Test2.dbo.MyTable
Test123.dbo.MyTable
Test223.dbo.MyTable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end