# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+(?<!Test1)\.dbo\.MyTable"
test_str = ("Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable\n"
"Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable\n"
"foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable\n\n"
"Test1.dbo.MyTable\n"
"Test2.dbo.MyTable\n"
"Test123.dbo.MyTable\n"
"Test223.dbo.MyTable")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.