using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?<!Test1)\.dbo\.MyTable";
string input = @"Test1.dbo.MyTable Test2.dbo.MyTable Test123.dbo.MyTable
Test223.dbo.MyTable Test1.dbo.MyTable Test1.dbo.MyTable
foo.dbo.MyTable foobar.dbo.MyTable Test1.dbo.MyTable
Test1.dbo.MyTable
Test2.dbo.MyTable
Test123.dbo.MyTable
Test223.dbo.MyTable";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}