#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:\.[05]0*)?$"
Local $sString = "12" & @CRLF & _
"22" & @CRLF & _
"10" & @CRLF & _
"10.0" & @CRLF & _
"12.0" & @CRLF & _
"15.5" & @CRLF & _
"15.005" & @CRLF & _
"15.12" & @CRLF & _
"11.000" & @CRLF & _
"12.500" & @CRLF & _
"12.522"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")