re = /^\d+(?:\.[05]0*)?$/m
str = '12
22
10
10.0
12.0
15.5
15.005
15.12
11.000
12.500
12.522'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end