using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:\.[05]0*)?$";
string input = @"12
22
10
10.0
12.0
15.5
15.005
15.12
11.000
12.500
12.522";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}