package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.[05]0*)?$`)
var str = `12
22
10
10.0
12.0
15.5
15.005
15.12
11.000
12.500
12.522`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}