// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.[05]0*)?$").unwrap();
let string = "12
22
10
10.0
12.0
15.5
15.005
15.12
11.000
12.500
12.522";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}