import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.[05]0*)?$";
final String string = "12\n"
+ "22\n"
+ "10\n"
+ "10.0\n"
+ "12.0\n"
+ "15.5\n"
+ "15.005\n"
+ "15.12\n"
+ "11.000\n"
+ "12.500\n"
+ "12.522";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}