import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n{2}|^)(?:(?:-|\\d+\\.) +.*\\n?)+";
final String string = "- one\n\n"
+ "some text\n"
+ "- should not start a list\n\n"
+ "- should start\n"
+ "- should continue\n\n"
+ "5. should also\n"
+ "6. more\n\n\n\n"
+ "5. should also\n"
+ "6. more\n"
+ "7. more\n"
+ "8. sdfs\n"
+ "9. sdfsf\n"
+ "10. sdfdsf\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}