use strict;
my $str = '- one
some text
- should not start a list
- should start
- should continue
5. should also
6. more
5. should also
6. more
7. more
8. sdfs
9. sdfsf
10. sdfdsf
';
my $regex = qr/(?<=\n{2}|^)(?:(?:-|\d+\.) +.*\n?)+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}