import re
regex = re.compile(r"(?<=\n{2}|^)(?:(?:-|\d+\.) +.*\n?)+")
test_str = ("- one\n\n"
"some text\n"
"- should not start a list\n\n"
"- should start\n"
"- should continue\n\n"
"5. should also\n"
"6. more\n\n\n\n"
"5. should also\n"
"6. more\n"
"7. more\n"
"8. sdfs\n"
"9. sdfsf\n"
"10. sdfdsf\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")