$re = '/(?<=\n{2}|^)(?:(?:-|\d+\.) +.*\n?)+/';
$str = '- one
some text
- should not start a list
- should start
- should continue
5. should also
6. more
5. should also
6. more
7. more
8. sdfs
9. sdfsf
10. sdfdsf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);