import Foundation
let pattern = #"(?<=\n{2}|^)(?:(?:-|\d+\.) +.*\n?)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
- one
some text
- should not start a list
- should start
- should continue
5. should also
6. more
5. should also
6. more
7. more
8. sdfs
9. sdfsf
10. sdfdsf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)