use strict;
my $str = '<value z:Id=\\"8\\" z:Type=\\"System.String\\" z:Assembly=\\"0\\">Status.</value>';
my $regex = qr/z:Assembly=\\"0\\">(?<fieldValue>(?:(?!<\/value>).)*)<\/value>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";