import re
regex = re.compile(r"z:Assembly=\\\"0\\\">(?<fieldValue>(?:(?!<\/value>).)*)<\/value>")
test_str = "<value z:Id=\\\"8\\\" z:Type=\\\"System.String\\\" z:Assembly=\\\"0\\\">Status.</value>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)