$re = '/z:Assembly=\\\\"0\\\\">(?<fieldValue>(?:(?!<\/value>).)*)<\/value>/';
$str = '<value z:Id=\\"8\\" z:Type=\\"System.String\\" z:Assembly=\\"0\\">Status.</value>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;