#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d+\.)(\w[\w\-]{0,24}\w)\."
Local $sString = "estadão.com.br" & @CRLF & _
"domínio.com.br" & @CRLF & _
"90.com" & @CRLF & _
"-errado.com" & @CRLF & _
"aindaerrado-.com" & @CRLF & _
"OK.com" & @CRLF & _
"1.com.br" & @CRLF & _
"1a.org" & @CRLF & _
"łðµsdaf.com" & @CRLF & _
"estadao.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")