import re
regex = re.compile(r"^(?!\d+\.)(\w[\w\-]{0,24}\w)\.", flags=re.MULTILINE)
test_str = ("estadão.com.br\n"
"domínio.com.br\n"
"90.com\n"
"-errado.com\n"
"aindaerrado-.com\n"
"OK.com\n"
"1.com.br\n"
"1a.org\n"
"łðµsdaf.com\n"
"estadao.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")